GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » Maf issues?
Previous thread Next thread

Maf issues?


Wolfpuss
Member
1392/2000


Galant VR-4 org Post #: 1185737 posted 08/23/14 07:14 PM     Remind Me!  Send Private Message   Edit Post      
Hey all-

I've been having issues with 1392.

Problem: Car runs super lean 95% (20 on the afr guage) the time. After countless hours of research/replacing parts, I've narrowed down my issue to a bad maf. My current maf would work when it wants to, so I bought another stock GVR4 maf. Installed the new (used) maf, can ran like crap on the first start up and even stalled. After restarting, the car began to run normal and started to register normal afr readings. Took it for a drive, and ran great. So I come home and shut her down thinking that my problem is solved..

Restarted the car after sitting for a hour, same thing. Afr is still on 20 and car runs like poop, bucking between 1-3k rpms.

I'm completely lost, so far I've replaced:

Spark plugs (gapped to .28)
Spark plug wires
Fuel filter
Fuel pump sock
Temp sensor
GVR4 maf (used)
FPR stock GVR4 (used)

Any advice would be great.

Thanks-
Randy

Posts: 157 | From: St Louis | Member Since: 07/08/14 | IP: (2600:100a:b10c:4) | Report this post to a Moderator

92_talon_awd
Member +
29/1000


Galant VR-4 org Post #: 1185738 posted 08/23/14 07:20 PM     Remind Me!  Send Private Message   Edit Post      
Open your ECU and look for carnage is what I suggest. Also check this really quick click



1992 VR4 29/1000 - Stock/Garage Dweller
2012 Jeep Grand Cherokee Overland Summit
2009 Harley Davidson Road Glide
2001 Toyota Tacoma TRD 4x4 - 405k miles
2005 Infinity G35 Coupe
2004 Chevrolet Express 3500 - 445k miles


Edited by 92_talon_awd (08/23/14 07:22 PM)

Posts: 456 | From: Knoxville, TN | Member Since: 02/11/14 | IP: (216.79.95.39) | Report this post to a Moderator

Wolfpuss
Member
1392/2000


Galant VR-4 org Post #: 1185785 posted 08/24/14 12:18 AM     Remind Me!  Send Private Message   Edit Post      
Opened up the ecu and I think it looks good. No blown caps or drivers.

Posts: 157 | From: St Louis | Member Since: 07/08/14 | IP: (2600:100a:b113:9) | Report this post to a Moderator

tektic
Senior Member


Galant VR-4 org Post #: 1185799 posted 08/24/14 10:28 AM     Remind Me!  Send Private Message   Edit Post      
How well versed are you with that software? You sure your using the right values for your particular setup?



7 1G DSM's now a GGSX build.

Posts: 1481 | From: ronkonkoma, ny | Member Since: 12/19/12 | IP: (24.45.85.14) | Report this post to a Moderator

FlyingEagle Galant VR4.org Moderator
Eager Beaver


Galant VR-4 org Post #: 1185800 posted 08/24/14 10:34 AM     Remind Me!  Send Private Message   Edit Post      
Quoting Wolfpuss:

Opened up the ecu and I think it looks good. No blown caps or drivers.





Why is the Eprom fuzzed out?



C53A 1 of the ~1500

Posts: 1622 | From: THE Ottawa | Member Since: 03/05/05 | IP: (99.248.124.9) | Report this post to a Moderator

Wolfpuss
Member
1392/2000


Galant VR-4 org Post #: 1185836 posted 08/24/14 02:53 PM     Remind Me!  Send Private Message   Edit Post      
Although I'm not an expert in dsmlink, the car is running on the same tune the car came with when I bought it. Tuned by Andre at Pina Motorsports



I blurred out the eprom on purpose.

Update today:

Tested the ISC and tested fine. I also unplugged the MAF and low and behold, a good afr bouncing from 14-15. But soon as I plug the MAF in, the car immediately runs super rich, about 20 and stays there.

So with that being said, is this a MAF issue?

Posts: 157 | From: St Louis | Member Since: 07/08/14 | IP: (24.207.133.113) | Report this post to a Moderator

iceman69510 Galant VR4.org Moderator
Turn Right Racing
855/2000


Galant VR-4 org Post #: 1186200 posted 08/26/14 09:59 AM     Remind Me!  Send Private Message   Edit Post   
Check the MAF wiring harness?



91 VR4 855 Nile Black
92 VR4 828 Belize Green-SOLD
91 VR4 115 Nile Black -SOLD

Posts: 10748 | From: Michigan | Member Since: 03/05/01 | IP: (205.144.100.200) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 4 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2264

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.176 seconds in which 0.153 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page