GalantVR4.org The Mitsubishi Galant VR-4 Forum
Galant VR-4 Forums » Galant VR-4 » Technical Discussions » why no boosting over 22psi
Previous thread Next thread

why no boosting over 22psi


Yao
Senior Member


Galant VR-4 org Post #: 1083587 posted 09/01/12 07:27 PM     Remind Me!  Send Private Message   Edit Post      
K, found what why it wouldn't boost past 22psi and dropped boost to 14psi at 6k.







What could cause this?? my manifold is whitish looking too, here are the pictures, is my tune off??? running too lean?








3"K&N, B16g, 2.5pipe, Synapse DV, ETS Frntmnt, FP4r, ZFG Long Block, 2g mani, evo3o2/5th, 3"exst,fic1100cc/walbro,
6an, poly mnts, DEL-abs/ps/4ws/egr/evp, Jack's tran, SB-clutch, evo8 whls-245/45/17/springs, 3kvr4 brakes, Koni, 4bolt rear,
ds-map, ntk.

Posts: 810 | From: Denver, CO | Member Since: 03/06/01 | IP: (67.176.15.69) | Report this post to a Moderator

Noobsauce
Member
1865/2000


Galant VR-4 org Post #: 1083589 posted 09/01/12 08:00 PM     Remind Me!  Send Private Message   Edit Post      
Looks normal to me. You have a Wideband to log your afr? I would have pressure tested and smoke tested before tearing everything appart

Posts: 159 | From: Beaverton, Oregon | Member Since: 04/07/12 | IP: (24.21.177.205) | Report this post to a Moderator

Yao
Senior Member


Galant VR-4 org Post #: 1083622 posted 09/01/12 11:29 PM     Remind Me!  Send Private Message   Edit Post      
Yeah, I am using Wide band to tune. If you look at the 2nd picture closely, you can see the chewed up/chipped turbine wheel.



3"K&N, B16g, 2.5pipe, Synapse DV, ETS Frntmnt, FP4r, ZFG Long Block, 2g mani, evo3o2/5th, 3"exst,fic1100cc/walbro,
6an, poly mnts, DEL-abs/ps/4ws/egr/evp, Jack's tran, SB-clutch, evo8 whls-245/45/17/springs, 3kvr4 brakes, Koni, 4bolt rear,
ds-map, ntk.

Posts: 810 | From: Denver, CO | Member Since: 03/06/01 | IP: (67.176.15.69) | Report this post to a Moderator

Galantvr4559
Member +
559/2000


Galant VR-4 org Post #: 1083630 posted 09/02/12 12:32 AM     Remind Me!  Send Private Message   Edit Post      
What size turbo?



559/2000

Posts: 264 | From: Denver, CO | Member Since: 07/15/11 | IP: (174.255.128.238) | Report this post to a Moderator

ade
Carbon Fiber Phallus Group Buy Member


Galant VR-4 org Post #: 1083678 posted 09/02/12 11:35 AM     Remind Me!  Send Private Message   Edit Post      
its on his sig, 18g





posting and you...

Posts: 303 | From: Paumanok NY | Member Since: 08/16/11 | IP: (71.167.139.251) | Report this post to a Moderator

Noobsauce
Member
1865/2000


Galant VR-4 org Post #: 1083715 posted 09/02/12 07:02 PM     Remind Me!  Send Private Message   Edit Post      
O ya I do see it now:) sorry I was on my phone before and didn't see that:)

Posts: 159 | From: Beaverton, Oregon | Member Since: 04/07/12 | IP: (24.21.177.205) | Report this post to a Moderator

Wizardawd
Senior Member
598/1000


Galant VR-4 org Post #: 1083780 posted 09/03/12 01:04 AM     Remind Me!  Send Private Message   Edit Post      
From what I can tell from the pics, the turbo and color is fine.

It's the exhaust manifold leak that's probably killing ya. You can see the leakage from the flange pic on the #4 cylinder exhaust port. And then look at the turbo pic where you can see a crap load of black soot all over your water pipe and the engine side of the compressor housing.

Wiz



598/1000 Nile Black
12/2000 Nile Black
1995 Montero SR
1997 Talon Tsi AWD Auto


Edited by Wizardawd (09/03/12 01:07 AM)

Posts: 1315 | From: Aberdeen, SD | Member Since: 08/08/07 | IP: (24.220.137.69) | Report this post to a Moderator

mitsuturbo
Banthony
555/1000


Galant VR-4 org Post #: 1083950 posted 09/04/12 01:43 PM     Remind Me!  Send Private Message   Edit Post   
That turbine wheel looks like it's shot. That sucks, man.

Also, your manifold could use a bit of port work. Taking that step out will probably help a bit. Your oil line needs to be replaced. It looks like it's falling apart. I guess when you replace the turbo you can fix that as well.



92 GVR4 555/1000 11.41 @ 128.26mph
97 CBR900RR
2012 Hyundai Veloster


Edited by mitsuturbo (09/04/12 01:44 PM)

Posts: 3535 | From: Near Seattle, Washington | Member Since: 06/02/08 | IP: (50.47.94.21) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 15 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker, iceman69510, pot, FlyingEagle 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 3994

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.177 seconds in which 0.157 seconds were spent on a total of 14 queries. Turbo powered.


Hertz's Galant VR-4 Page