GalantVR4.org The Mitsubishi Galant VR-4 Forum
NOTICE: This forum is for archiving information and discussions. Please do not reply to threads unless you have valuable information to add. Do not post questions or problems here.

Galant VR-4 Forums » Galant VR-4 » How To and Info Archive » Installing ECMLink into a JDM car.
Previous thread Next thread

Installing ECMLink into a JDM car.


kumfasa
Member


Galant VR-4 org Post #: 1229409 posted 06/20/16 04:41 AM     Remind Me!  Send Private Message   Edit Post   
It seems that there is a lot of conflicting information published online regarding the installation and use of ECMLink in JDM VR4's.
I have read that some wires need to be swapped in the ECU connector to get it to work.
I have read that some functions of the software are unusable in a JDM car.
I have read that people can't even get their car to start after installing the chip.
I have read...
The list goes on.

All of this put me off getting ECMLink, but if Tom Tharp can get it to run a Turbo Miata I thought why not give it a go.

I even emailed Thomas Dorris prior to purchase to see what he knew and his response was "
The only difference that I'm aware of is that the JDM ECU has an output for the cyclone intake manifold butterflies that the DSM ECU (and ECMLink code) treat as an EGR output. You can adjust the activation of the EGR output in ECMLink using the "ECU Config->EGR" tab if you feel this is a problem."

I order ECMLink V3 along with an LC-2 wideband kit.

I had a completely stock and unmodified 1991 JDM Evo 0 VR4. Immaculate condition inside and out and only 90,000miles from one Japanese owner.
I changed nothing at all from stock prior to installing ECMLink.
I did however make sure that each and every subsystem of the vehicle worked as it should. All filters replaced. All Maintenance performed. Any required repairs undertaken.

If anybody cares about the details of the work performed PM me.

I'm not sharing this to show off but to paint an accurate picture of my car's situation prior to installing ECMLink.

My ECU is labeled "MD165808" E2T37275.
I installed the chip into the ECU connected my laptop via the provided cable and started the car.

It fired right up and ran fine. I altered the fuel settings and dialed in the idle airflow checked that everything was working as it should and went for a drive. The rest is history.

Some things I discovered.

EGR
There is no EGR system on my car from factory and I discovered that the EGR solenoid output from ECMlink actually operates the Cyclone actuation solenoid.
I was able to figure this out by using the Solenoid activation buttons in the "Misc" tab of ECMlinks ECUConfig. Listening to the solenoids while switching them on and off.
This is actually a really good thing as I can now set my Cyclone activation point to by enabling "User-defined settings on the EGR tab of ECUConfig.

EVAP
M cars EVAP canister purge is not driven by a solenoid but operates solely by vacuum from the P port on the top of the throttle body.
So the output for the EVAP solenoid in ECMlink actually triggers a dash warning light for the Catalytic Converter Temperature warning.
My car has a small temp sensor that goes into the exhaust just behind the Catalytic converter.
This means that my Cat Temp warning light on the dash flashes on when the right criteria are met, which appears to be part throttle with low load or anytime there is vacuum that is not idle or deceleration.
I intend to either remove the bulb from the instrument cluster or pull the corresponding wire from the ECU connector.

Some of the resources I used to help me make the decision to install and also to understand the differences in the wiring loom were the pinout diagrams below.

Something else to consider... Im not sure if there are differences between the Evo 0 JDM model and the older ones 87-90 model years, so I cant speak to that. The pinout diagrams below would indicate that there are. But im sure that it is nothing that could not be easily fixed with a bit of smarts and the moving of some wires in the ECU connector.

Cheers
Andrew







Posts: 114 | From: Tauranga, New Zealand | Member Since: 02/28/15 | IP: (58.28.212.87) | Report this post to a Moderator


Pages: 1
Previous thread Next thread

Extra information
0 registered and 2 anonymous users are browsing this forum.

Galant VR4.org Moderator:  curtis, steve, atc250r, jcgalntvr4-244, cheekychimp, jepherz, Rausch, toybreaker 

Print Thread

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 1634

Rate this thread


News & Events: News | Events
Galant VR-4: Newbies | General VR4 Discussions | Technical Discussions | How To and Info Archive
Marketplace: Parts For Sale | Cars For Sale | Good Guys | Bad Guys
Community: Members' Showcase

Contact Us | Privacy statement GalantVR-4.org

Generated in 0.071 seconds in which 0.031 seconds were spent on a total of 14 queries. Turbo powered.



Hertz's Galant VR-4 Page